Forum

Can't receive data from touch OSC

Hi!
I recently bought TouchOSC app and I’m trying to learn how to use it with vvvv, but I can’t receive data from the app.

Using the simple patch of vvvv that you can see here below and a ultra-simple layout on TouchOSC (with just one fader) I can send data to the iPad but I can’t send data back to vvvv.

I post even the settings of the iPad.
What’s wrong? Please help me 'cause I can’t solve this problem…

thanks

sounds like you mess up ports, address or ip…

Interesting,

I have been having the exact same issue. What setup are you using?

I have tested on a Windows 7 laptop on a university network that sometmes has restrictions and it works correctly.

I have also tried using a Bootcamped Mac with windows 8 pro and on that machine it worked temporarily and then stopped. 4v stopped receiving messages but could send them to Touch OSC.

Its very frustrating.

Be careful of course that running two UDP servers can block eachother

H

I included in the first message the images of the IP settings and the patch screenshots … maybe we have to wait that moderator should approve them.
(excuse me, this is my first thread)

I’m using a Win10 on Asus Laptop.
What’s strange is that I can transmit data in both ways using Pure Data, so general connections and settings are fine. Something’s wrong in my vvvv patch I guess…

Also check Win firewall, you may need to allow vvvv to do stuff.

Hi man… post your patch…

when u add a screenshot u also have to press button “insert image” near the upload.
afterwards you can press button edit message scroll to the bottom and fix it.

p.s. most common mistake with osc is mismatching ports…

Hi!these are the screenshots!

this is the simple patch i’m using for the test:

and these are the screenshots of the iPad settings:

I checked the firewall settings and I found that my personal WLAN was set as public network so there were restrictions on input traffic!

Thank you all for your priceless help!