Cant go fullscreen with EX9 renderer

Hey there i was trying to open an older patch Dx9 and it wouldnt let me go fullscreen.
If i press ALT+ENTER goes fullscreen but its all black.
In the inspector fullscreen dimensions are set to “as desktop”
Fullscreenformat is set to “X8R8G8B8”
Fullscreen refresh rate also “as desktop”

this all just happens when there is only a quad connected to the renderer. so no big computing is involved.
when i exit the fullscreen mode it takes a while for the renderer to display the quad again.

with Dx11 there is no problem right now.
do you have expierienced something similar and maybe know a solution?

i uploaded my fullscreen monsterpatch if you want to check if there is something configured wrong ,)

thanks fo the help.


Fullscreen Problem.v4p (1.7 KB)

is it maybe the same as this? When going fullscreen render is black (ex9)

works here, can you try with setting specific values to the “As Desktop” enums? does it work then? also does the auto aspect setting change something regarding this behavior?

hey ho,

its the same as the thread “when going fullscreen render is black”
i tried all dirfferent kind of settings but none of them work.
even reinstalling vvvv and directx9 didnt had any effect.

i also think that it has to do with the windows update. i didnt open the old patch after the win10 update but before that it fully functioned.

the thing is that when try the patch on my desktop pc it runs. on my laptop it dont…

well, i’ve would try with a new patch, and fullscreen just check if that’s an issue with a patch or vvvv

jea i tried a whole new patch but it stays the same.
only when going fullscreen on a different monitor and then clicking the renderer node it gets visible as referred in the When going fullscreen render is black (ex9) thread.

Which model is a pc? I know on msi there were some bloatware makes second render window really slow maybe that’s a blotware process blocking it?

Second thought that dx/ex command look for /dx9


¿Has someone found a solution for this problem? I have the exact same issue.


@Ricardo does this solve it?

It does, thanks!!!

awesome :)

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.