C# default() cause exception in VL?

source code:




original snippet code:


also source code turns into node with two inputs that didn’t used in snippet:


looks like it’s problem with casting and I dont know how to deal with it


Can you upload a test patch please?

That’s it
debroglietest.vl (35.2 KB)

Thanks. Will be fixed in upcoming bugfix release - for a sneak preview look here.

Regarding the cast exception. Tricky one, was also confused for quite a while. Turns out there’re two AdjacentModel.Create overloads and one must pick the one with ITopoArray<Tile> and not ITopoArray<T> - see screenshot:


1 Like

@Elias I’ve tried both of overloads and both of them not worked as expected, in any combination. At best, it writes about cast. Anyway, when I try to add ToValueArray then the exception throws out

Can I download it?

Thank you!

Go to the Artifacts tab and then at the very bottom you find the setup.exe

Well look at my screenshot above, this was the state where it worked for me. When you hover the Sample input of that node it must read ITopoArray<Tile> and NOT ITopoArray<T>

It’s working with fixes from gamma preview!
Many thanks!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.