Forum

Bug in b26: Error on startup

Getting this error on startup from one of my machines. Crack.exe says that all dependencies are installed. Old version runs fine (45beta25.1).

Log from /logstartup (let me know if I can add any more info):

16:37:21.482 everything you know is wrong
16:37:21.482 creating SplashScreen
16:37:21.497 setting environment variable for opencv .dlls to \bin
16:37:21.497 creating GClock
16:37:21.513 creating GMainloop
16:37:21.513 creating GLog
16:37:21.513 creating GApplication
16:37:21.513 creating GGlobals
16:37:21.544 creating GNodeFactory
16:37:21.544 creating Gex9Base
16:37:21.560 Direct3D initialized.
16:37:21.560 ExceptionDialog is disabled. Start vvvv with /showexceptions to enable it.
16:37:21.575 enumeratig Game Devices…
16:37:21.607 found Game Devices:
16:37:21.607 enumerating Midi Input Ports…
16:37:21.607 found Midi Input Ports:
16:37:21.607 enumerating Midi Output Ports…
16:37:21.607 found Midi Output Ports: “Microsoft GS Wavetable Synth”
16:37:21.622 enumeratig TAPI Devices…
16:37:21.622 found TAPI devices:
16:37:21.622 enumeratig Audio Renderer Devices…
16:37:21.638 found Audio Renderer Devices: “Realtek Digital Output (Realtek”,“Default DirectSound Device”,“Default WaveOut Device”,“DirectSound: Realtek Digital Output (Realtek High Definition Audio)”
16:37:21.638 enumeratig Midi Renderer Devices…
16:37:21.638 found Midi Renderer Devices: “Default MidiOut Device”,“Microsoft GS Wavetable Synth”
16:37:21.638 enumeratig External Renderer Devices…
16:37:21.638 found External Renderer Devices:
16:37:21.638 enumeratig Audio Input Devices…
16:37:21.638 found Audio Input Devices:
16:37:21.638 enumeratig Video Input Devices…
16:37:21.653 found Video Input Devices: “PS3Eye Camera”
16:37:21.669 creating MainForm
16:37:21.700 creating AddonHost
16:37:22.262 vvvv caused error during startup: The composition produced multiple composition errors, with 2 root causes. The root causes are provided below. Review the CompositionException.Errors property for more detailed information.

  1. Could not load file or assembly ‘VVVV.PluginInterfaces, Version=2.0.4245.31395, Culture=neutral, PublicKeyToken=null’ or one of its dependencies. The system cannot find the file specified.

Resulting in: An exception occurred while trying to create an instance of type ‘VVVV.Hosting.Factories.DotNetPluginFactory’.

Resulting in: Cannot activate part ‘VVVV.Hosting.Factories.DotNetPluginFactory’.
Element: VVVV.Hosting.Factories.DotNetPluginFactory --> VVVV.Hosting.Factories.DotNetPluginFactory --> AssemblyCatalog (Assembly=“VVVV.Hosting, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null”)

Resulting in: Cannot get export ‘VVVV.Hosting.Factories.DotNetPluginFactory (ContractName=“VVVV.PluginInterfaces.V2.IAddonFactory”)’ from part ‘VVVV.Hosting.Factories.DotNetPluginFactory’.
Element: VVVV.Hosting.Factories.DotNetPluginFactory (ContractName=“VVVV.PluginInterfaces.V2.IAddonFactory”) --> VVVV.Hosting.Factories.DotNetPluginFactory --> AssemblyCatalog (Assembly=“VVVV.Hosting, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null”)

Resulting in: Cannot set import ‘VVVV.Hosting.HDEHost.AddonFactories (ContractName=“VVVV.PluginInterfaces.V2.IAddonFactory”)’ on part ‘VVVV.Hosting.HDEHost’.
Element: VVVV.Hosting.HDEHost.AddonFactories (ContractName=“VVVV.PluginInterfaces.V2.IAddonFactory”) --> VVVV.Hosting.HDEHost

  1. Could not finishing composing object of type ‘VVVV.Hosting.Factories.DotNetPluginFactory’. The import ‘VVVV.Hosting.Factories.DotNetPluginFactory…ctor (Parameter=“parentContainer”, ContractName=“System.ComponentModel.Composition.Hosting.CompositionContainer”)’ was not satisfied.

Resulting in: Cannot get export ‘VVVV.Hosting.Factories.DotNetPluginFactory (ContractName=“VVVV.Hosting.Factories.DotNetPluginFactory”)’ from part ‘VVVV.Hosting.Factories.DotNetPluginFactory’.
Element: VVVV.Hosting.Factories.DotNetPluginFactory (ContractName=“VVVV.Hosting.Factories.DotNetPluginFactory”) --> VVVV.Hosting.Factories.DotNetPluginFactory --> AssemblyCatalog (Assembly=“VVVV.Hosting, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null”)

Resulting in: Cannot set import ‘VVVV.Hosting.HDEHost.PluginFactory (ContractName=“VVVV.Hosting.Factories.DotNetPluginFactory”)’ on part ‘VVVV.Hosting.HDEHost’.
Element: VVVV.Hosting.HDEHost.PluginFactory (ContractName=“VVVV.Hosting.Factories.DotNetPluginFactory”) --> VVVV.Hosting.HDEHost

2011.09.19-16.37.21.txt (4.3 kB)

hm, did you by any chance not extract the .zip correctly? in your vvvv directory there is supposed to be a dir called
\bin\managed
that holds 31 files including a file called
VVVV.PluginInterfaces.dll

is this the case?

Yep, that seems to be in the right place. Here is what I see in that dir:

Volume in drive C is HP
Volume Serial Number is 0488-7F8E

Directory of C:\vvvv\bin\managed

09/19/2011 05:03 PM .
09/19/2011 05:03 PM …
09/19/2011 04:35 PM 3,584 BinManaged.dll
09/19/2011 04:35 PM 26,624 CommandLine.dll
09/19/2011 04:35 PM 31,364 CommandLine.xml
09/19/2011 05:03 PM 0 dir.txt
09/19/2011 04:35 PM 528,384 ICSharpCode.NRefactory.dll
09/19/2011 04:35 PM 352,256 ICSharpCode.SharpDevelop.Dom.dll
09/19/2011 04:35 PM 270,336 log4net.dll
09/19/2011 04:35 PM 29,760 Microsoft.Practices.ServiceLocation.dll
09/19/2011 04:35 PM 133,944 Microsoft.Practices.Unity.dll
09/19/2011 04:35 PM 362,906 Microsoft.Practices.Unity.xml
09/19/2011 04:35 PM 376,832 Mono.Cecil.dll
09/19/2011 04:35 PM 32,704 Nito.Async.dll
09/19/2011 04:35 PM 38,630 Nito.Async.xml
09/19/2011 04:35 PM 3,407,872 SlimDX.dll
09/19/2011 04:35 PM 2,569,217 SlimDX.xml
09/19/2011 04:35 PM 245,760 System.ComponentModel.Composition.dll
09/19/2011 04:35 PM 319,623 System.ComponentModel.Composition.xml
09/19/2011 04:35 PM 393,216 System.Threading.dll
09/19/2011 04:35 PM 135,168 UMD.HCIL.Piccolo.dll
09/19/2011 04:35 PM 493,483 UMD.HCIL.Piccolo.xml
09/19/2011 04:35 PM 73,728 UMD.HCIL.PiccoloX.dll
09/19/2011 04:35 PM 186,754 UMD.HCIL.PiccoloX.xml
09/19/2011 04:35 PM 208,896 VVVV.Core.dll
09/19/2011 04:35 PM 45,056 VVVV.HDE.Viewer.PiccoloGraphicalEditor.dll
09/19/2011 04:35 PM 61,440 VVVV.HDE.Viewer.WinFormsViewer.dll
09/19/2011 04:35 PM 155,648 VVVV.Hosting.dll
09/19/2011 04:35 PM 81,920 VVVV.PluginInterfaces.dll
09/19/2011 04:35 PM 184,935 VVVV.PluginInterfaces.xml
09/19/2011 04:35 PM 86,016 VVVV.Utils.dll
09/19/2011 04:35 PM 136,539 VVVV.Utils.xml
09/19/2011 04:35 PM 28,672 VVVV.Utils3rdParty.dll
09/19/2011 04:35 PM 39,139 VVVV.Utils3rdParty.xml
32 File(s) 11,040,406 bytes
2 Dir(s) 173,161,025,536 bytes free

More info:

The machine is a AMD Athlon X2 250 running Win7 64-bit with 4gb RAM. Graphics card is a Quadro 4000.

Let me know if I can get you any more info today. I’m going to wipe the machine and do a reinstall later today to try to get it up and running again (need it for boygrouping).

Thanks,
joel

too bad. i have no idea what that could be…where to look…

Strange, it is still happening after a clean wipe and reinstall! :(

I did the following:
reformatted the hd
installed Win7 x64 Pro
installed Google Chrome
installed TortoiseSVN
installed NVidia’s latest drivers for Quadro 4000
reboot
installed DX9 (redistributable recommended by crack.exe)
started vvvv

Got the same exact error. The only thing I could think of is that this is an issue running on the AMD Athlon? All my other machines are running on Intel’s and don’t have this issue (though it seems strange that this would be processor dependent).

From the error text I am getting I am guessing that some assembly that vvvv references was compiled with a dependency on a specific version of a different assembly (and this changed between b26 and the last version).

Ok, fixed it but I’m not sure what did it. I deleted my vvvv directory entirely, redownloaded the zip and then extracted it into a new directory (using the “Extract All…” context menu option). Tried to run in the new director but it claimed I needed to run crack.exe. I did that and then vvvv started up just fine.

I’m guessing that is is mostly user error but it seems like crack.exe might be registering vvvv assemblies and somehow it skipped them on the first run through? My directory contents seemed ok and even copying a working version over from another computer didn’t seem to do the trick.

Anyways, back up and running now. It seems like vvvv could probably benefit from an installer that handles some of this process for you (“crack.exe” does not inspire confidence exactly…). Still, I love the death out of this program, thanks for keeping it going strong!

well, then glad you made it and sorry for the inconveniences.