Boygrouping with Kinect-- not so easy

I am trying to use the OpenNIGenericNode with a Kinect on a client computer for a 2 computer setup. The kinect operates fine on the server computer; but not on the client computer where i need it. When not in boygrouping mode the same computer opens it just fine. Has anybody else tried boygrouping with the kinect?? Is there a special trick for opening devices on a client computer?

Just for understanding:
Is the Kinect-node boygrouped?
If yes: is a Kinect connected to the client?

Yes- the kinect node is boygrouped and the kinect is connected to the client.

Another Kinect connected to the server?

No. Just one kinect. I could borrow another kinect but i don’t see the point of connecting one to the server. Would it help?


i just tried to create both versions of the Kinect node on a boygroupserver without a connected device.

i didn’t wonder about both nodes turning red more or less immediately.

which beta are you refering to?
hopefully >=27…

I’m using 25.1 but I will switch over immediately if that helps me with my problem.

OK so I upgraded to vvvv 27.1 and now nothing works. All kinect related nodes are red; open NI generic node is said to be missing even though I downloaded it twice and put it in the plugins folder. I even get the same result when I open v 25.1 ?!?! Re-installed the drivers, banged head against table, still nothing. Same thing happened on my other computer when I switched to 27.1 (but it still works on 25.1) Of course this stuff only happens the night before a big gig, right?
Any insight would be tremendously appreciated

Hey htone,

no need to download any plugins in b27.1 anymore - the Kinect Nodes are part of the addonpack as of 27.1.
Further information: kinect
Also check if you have the latest drivers for the included OpenNI Nodes.

Depending on what you’re trying to achieve, also vux’ Kinect (Microsoft) Node might be of interest.
Since it’s using the beta SDK, it’s restricted to RGB, Depth and Skeleton.
Restricted to 64bit systems though.

On my hardware it was much more stable than OpenNI.

Good luck!

I reinstalled the drivers as per the recommendations on the kinect thread-- not using the auto installer like before-- and I finally got it to work. OpenNIGenericNode appears to be lost forever, never to work again (as well as other stuff from the old openNI package) but that’s ok because the Users node did what I needed. I would try the Microsoft node but would that involve totally changing the drivers and everything?
About halfway through the 4 hour set the kinect crapped out on me and I just had to live without it because I couldn’t reboot the whole system at that point. I wonder if there’s any way to deal with situations like this-- maybe I will start a new thread…
Thanks everyone for your help-- the kinect is brilliant yet moody and cantankerous. Hope to tame it someday.

‘maybe I will start a new thread’

Exactly! There is functionality in the alpha release which lets you share a texture between vvvv instances (each instance running in a separate thread, and it should be possible to have one instance devoted to the kinect plugin, sharing whatever textures you need.

Then if the kinect freezes, you just restart that vvvv instance, while the other instance(s) generating the output stay running