Boygrouping help asked

I’m getting started with boygrouping. I got 2 pc’s in a network and got the VVVV client and server running. On my server I can see the client is connected. So that seems to be ok.

I made a simple patch with a quad and a renderer(ex9) and i’m seeing a render window with the quad in it. Now when I make those two nodes, boygroup nodes with CTRL+B the render window stays visible but on the client side nothing happends. Only the “client for 192…” window.

Am I doing something wrong in VVVV or could it be a netwerk issue?

boygrouping works for me on beta25, open the attached patch and set the IPs right. hope it works:

boygroup_tester.v4p (6.3 kB)

Thanks, but it’s not working. On the server side everything looks ok. I can see the I/O toggle shows the client is connected. But on the clientside nothing happends.

Should i see only the render window on my client?
Do i have to transfer any extra files to the client?

I’m using VVVV 45beta24.1

Had the same Problem, disabled the WinXP-Firewall…
(Do You put the right IP into the Broadcast-IP-Node?)

mfg chmee

right, could be a firewall setting… your software setup seems to be correct.

Tried a lot to solve the problem but nothing helps…Opened port 4444 but wont do. Is there a way to check if the network is setup right? I can ping both computers both ways and the boygroup (server) tells me the client is connected. Is this a guarantee that network is ok or could there be another reason why connection is visible in VVVV but client can’t receive anything.

Is there a way to check if me client gets answers from the server? Now i can only see that the server can see the client (boygroup connected pin) but can’t see if the client can ‘see’ the server (maybe a node wich shows connection state from client to server?).

the Renderer (TTY) will output some messages. it is possible that your router has disabled the UDP broadcast, but i am not sure if thats really required. you can also try the TCP mode on the Boygroup (Server).

you mean
*on the Server the renderer stays visible
*on the client you see only that little patch window in the upper right corner?

but you checked that the client is able run vvvv in general?
do you have different amounts of screens connected to server and client?
maybe the client tries to move the renderer into an area out of the display?
only some wild guesses.

Thanks for all suggestions but none of them solves the problem, however I found out it works when I put the server on the ‘client’ computer and put the client on the ‘server’ computer. The testpatch started working immediately after I put in the client IP. So it looks like it has something to do with rights in my network I think…

Does the client send information back to the server is it a one way data stream from server to client?

It doesn’t matter for now wich computer is used as server, but I will try to understand the problem to avoid future problems, when I solve the problem I will post the solution.

sounds like a reinstall of windows required maybe.

like @chmee suggested:

on the Boygrouping (Server) there is a hidden Broadcast IP. vvvv tries to figure out the broadcast IP by itself but in rare cases seems to fail. then just try setting it manually to something like
depending on your subnet.

Hi boys

Iam trying to understand how all this grouping work

i have

as i understand broadcast ip pin should has ip of the server.

But if there is ip of server my client doesn’t respond, it freeze frame (it refresh for one frame only when i delet ip of clinet and write it again to boygroup node)

If i change broadcast ip to client ip, client start to work.

Now i play with one client, but what if i have more clients? should i have to write all the client ips to the broadcast pin?
Or am i something missing?


the ip of your server is not a broadcast ip. a broadcast ip typically ends with 255, so in your example it should be

you still need to add your clients one by one to the Clients pin, as all the changes you make to your patches are sent out to these addresses via the tcp protocol while the broadcast ip is used to send the data from server nodes to those blue boygrouped nodes via the udp protocol.


only way to render on client is to set in broadcast ip - ip of client
tty =
Network received request dump message from machine 1
ServerCommander received request dump, sending complete graph to machine 1
sent clear graph
ServerCommander sent complete graph to machine 1
Network receive ping message from machine1

in case on broadcast pin
tty = Network knows that server disconnected from

i have turn of firewall, using cable connection, same vvvv
on server have double ethernet

i have try use client pc as server and it behave same way

hm…if does not work for you there must be something wrong with your network. as elias pointed out broadcast adressess end in .255 and that means that all clients will receive the message.

probably try
and you set this in the Broadcast IP of Boygrouping (Network Server), right?

do you have by chance two network adapters? if so, how they’re configured?

thank you .255 is working
but for me this work only in TCP mode and if i send some LFO from server to client to translate, movement is very jerky

any idea what should be wrong with my connection?
(in know that tcp is slower, but why doesn’t work udp)
udp connection is from help is working


k. so for some reason udp-broadcasting is not working for you. when in TCP mode the .255 is not used. TCP does not have a broadcast option.

a quick google returned several possible causes for udp-broadcasts to fail:

  • does your server have multiple network cards? (try to make the one you want to use the master, or disable the other one if you don’t need it)
  • are you on windows embeded? (install the firewall and then disable it)
  • as Network Port try something between 49152 and 65535 instead of the default 3333

hope that helps. else more reasons could probably found by googling…


i have changed broadcast ip to and its working

now LFO run smoothly but manual changing values is like on cross country

hm, can you comment on the other options i proposed? did none of them work?

beware that doing this on a larger network can cause quite some spam/jam. as long as you’ve a dedicated boygrouping network with nothing else going on i think this should be fine. still only a .255 as the last digit should work and there is something odd with your setup.

also odd, since there is no difference if you send an lfos output or a manual change via udp. in both cases you should include a blue damper below the changing value so that it gets smoothed on the client as mentioned here: boygrouping basics#the blue nodes