Forum

Bheringer bcr2000 rotary

hi!
i’ve bought a behringer bcr2000 rotary controller to use it with 4v.
i’ve seen that this model was already tested by other users and i’m trying with 020200\dxnr\tonfilm patch BCR2000-Midicontrol (Devices) help (not the one adapted for bcf2000).
It seems to work both in input and output from 4v; but just for few seconds.Then 4v seems to not receive anymore inputs from the controller, even if the led’s position of the rotary’s stills change as i turn it.The output function from 4v to bcr2000 still work.
I actually have not idea of which the problem could be.
Frist i’ve tryed with the newer driver: version 1111.
Since i’ve encountered the described problem i’ve tried also with 1110 version, but the problem lasts.I’ve set the controller to U-1 modality while installing the driver (as the driver file’s info indicates).
does anyone use bcr2000 with windows xp sp2?
which firmware version are u using, 107 0r 110?

Hi Solanina,

I played around with the help patch quite some while ago and I extended the help patch. I haven’t experienced the trouble that you’re currently dealing with, so I have to check it on my new system. My BCR2000 is currently at someone else’s studio, so I will first have to pick it up before I can test stuff… This will probably be after the weekend, so I hope you can wait a few days…

Cheers,

XNDR

( the controller works with both ableton live and max\msp on OsX )

A program called “midi-ox” supplied me with the required diagnostics every time I had trouble setting up midi devices. It logs all midi events and much more… Perhaps it can help you out too…?

Midi-Ox website

I think I use u5 or 3, cant remember, but the first bcr’s I had had exactly that problem but it was hardware, midiox stopped displaying messages as well, as did osx.
But if it works with them I’m foxed!

hi!
i’ve tryed with midiox… it seems to detect the midi device but not be able to receive data,like in vvv.
At midiox’s startup a message is showed: startallmidin failed.
don’t know axactly what it could mean.
the Controller still receive outputdata from 4v but no inputs are detected.
Do u have any idea of what i can checkout?
any knowed forum to search in?
********************************___

Cheers
S

If its new and bought from a shop, take it in and get them to test it, or if there is a frendly music shop try and get them to test it anyway, as I said 2 failed in the same way for me, and it was definatly a hardware bug, they still output midi via the din sockets but usb stopped working after 5 seconds to 5 minutes. Test on another PC to see if it is just an incompatibility with your hardware, try it on the other u settings.
After that contact customer support?

hi!
still trying to make the bcr2000 work, no sucess…
it works in vvvv for 3 seconds, output and input ok,
then stops sending data to vvvv but continues working in input (i move a slider in vvvv->the leds on the bcr2000 move),
then it stop working even in input (no more leds moving when i move vvvv faders).
I tried everything,
unistalled the x-session driver from the system, coz i thought it could conflict with the behringer, nothing…
reinstalled the soundcard drivers, nothing…
remove the midi devices from the win registry with midifix to avoid the max 10 items limit, nothing…
banging my head on the wall and swearing to god, nothing…
try on another imac i got with ableton live… it works perfectly…
can the unit be considered broken if it works on OSX???

this is the midi-ox report, it works for 3 seconds than display the error message-> StartAllMidiin Failed -dev:0
if I exit midi-ox and restart it, the error mssage appears immediately…
If i ask for the Device Information, it displays this even after the error message " StartAllMidiin Failed -dev:0 " has appeared (see later)

anyone got any advice?

TIMESTAMP IN PORT STATUS DATA1 DATA2 CHAN NOTE EVENT
Opened MIDI Input
Opened MIDI Output
00000000 1 2 B0 01 01 1 — CC: Modulation
000009B7 1 2 B0 01 02 1 — CC: Modulation
000009CC 1 2 B0 01 03 1 — CC: Modulation
000009DF 1 2 B0 01 04 1 — CC: Modulation
00000A02 1 2 B0 01 05 1 — CC: Modulation
00000A3B 1 2 B0 01 06 1 — CC: Modulation
00000A5E 1 2 B0 01 07 1 — CC: Modulation
00000A8D 1 2 B0 01 08 1 — CC: Modulation
00000ABE 1 2 B0 01 09 1 — CC: Modulation
00000AF5 1 2 B0 01 0A 1 — CC: Modulation
00000B74 1 2 B0 01 0B 1 — CC: Modulation
00000BA1 1 2 B0 01 0C 1 — CC: Modulation
00000C46 1 2 B0 01 0D 1 — CC: Modulation
00000C8C 1 2 B0 01 0E 1 — CC: Modulation
00000D02 1 2 B0 01 0F 1 — CC: Modulation
00000D42 1 2 B0 01 10 1 — CC: Modulation
00000DA9 1 2 B0 01 11 1 — CC: Modulation
00000E02 1 2 B0 01 12 1 — CC: Modulation
00000E6E 1 2 B0 01 13 1 — CC: Modulation
00000EA0 1 2 B0 01 14 1 — CC: Modulation
00000F30 1 2 B0 01 15 1 — CC: Modulation
00000FAC 1 2 B0 01 16 1 — CC: Modulation
00001010 1 2 B0 01 17 1 — CC: Modulation
0000109B 1 2 B0 01 18 1 — CC: Modulation
00001118 1 2 B0 01 19 1 — CC: Modulation
000011AF 1 2 B0 01 1A 1 — CC: Modulation
00001273 1 2 B0 01 1B 1 — CC: Modulation
000012B5 1 2 B0 01 1C 1 — CC: Modulation
0000139F 1 2 B0 01 1D 1 — CC: Modulation
00001410 1 2 B0 01 1E 1 — CC: Modulation

If i ask for the Device Information, it displays this even after the error message " StartAllMidiin Failed -dev:0 " has appeared:

DEVICE INFORMATION
IN: 1) BCR2000 01
OUT: 2) BCR2000 01
In: 1) BCR2000 01
Details/Chan: 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,CM,RT,Sx
In: MIDI-OX Events
Details/Chan: 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,CM,RT,Sx

it works in vvvv for 3 seconds, output and input ok,
then stops sending data to vvvv but continues working in input (i move a slider in vvvv->the leds on the bcr2000 move)

when i looked into that patch i wondered about no “+ (Value Spectral)” behind the change animation. i wonder if this one here works.

did you play around with buffer length?

do you use same MIDIchannels for IN- and Output? may that cause something like a feedback?

i only can guess because i don’t have that device…

BCR2000-Midicontrol (Devices) help.v4p (36.4 kB)

hey. i have a bcr2000 right next to me. and i have the vvvv patch opened posted by kalle above. both in and output work. i just had to switch the midi out device from MS wavetable synth to bcr2000.

what didnt work was using the same I/O boxes as in and output at the same time.

i am using the BCR2000 for a long time now on several machines with vvvv and it never failed. one thing though: when the proper driver has been installed, you have to plug in the USB cable to the same port as always, otherwise the BCR isnt fully functional because its treated like a standard compliant midi device. windows :(