Forum

Beta27 bugs?

hi there,

there are strange tings happening here ;)

beta27 doesnt find his own nodes in /lib/nodes/modules… via node-browser or doubleclick…

example

NIL (Spreads)…

but…

if you drop that nil (spreads).v4p in an patch --> voila… the node appears in nodebrowser / -list… but only till closing…

same thing with ALL nodes in that directory…

pointing root.v4p direct to that directory (f.e. /modules/Spreads) doenst change anything :(

environment --> macbook with win7 x64

same thing with xmas-pack

thanks in advance ;)

vvvv has new folder structure.
So, be sure to extract the .zip over your vvvv directory so that the \addonpack directory is placed just next to the \girlpower directory

how many nodes should be found in fresh instal directory?https://vvvv.org/sites/default/files/imagecache/large/images/NodeList.JPG
945?

@dimix: is this really how your root looks like?
because @all: it should not look for \vvvv_45beta27 and \vvvv_45beta27\addonpack but:
\vvvv_45beta27\lib\nodes
\vvvv_45beta27\addonpack\lib\nodes

that would explain why you’re missing nodes but i’d have no idea how you got there if that is really the problem

also: is “_aSYSTEM_FOLDER” an actual directory of yours? or is that a bug?

@joreg:

  1. it’s not a bug, “_aSYSTEM_FOLDER” is my “specific” directory
    2.^quote:joreg:
    because @all: it should not look for \vvvv_45beta27 and \vvvv_45beta27\addonpack but:

\vvvv_45beta27\lib\nodes
\vvvv_45beta27\addonpack\lib\nodes
^
following install instructions I get this structure, but still dont have direct access to some nodes, ex. chess.fxhttps://vvvv.org/sites/default/files/imagecache/large/images/Directory.JPG

update:

meanwhile addon-pack worked…

but absolutely NO LUCK with xmas pack…

all “my” downloaded contribs worked (liked path in root.v4p)…

if i add xmas-folder in root.v4p the count in nodelist increases by 1(!!)…

if i take the whole folder-structure and copy to my contribs or addonpack-folder - the count in nodelist stays at the same value as before. none of the nodes where found.

if i open the v4p-files manually - all nodes are red :( they link to a dir, that doesnt exist.

i dont have that security-warnings in all .dlls

thanks in advance
grobkorn

update2…

if i open the todo_helpfile - all todo-nodes appears in nodelist… :(
worked only with helpfile…

So in your root patch you should have the full path to the dirs that contain the folders ‘module’ ‘plugin’ etc

In the case of the addons or xmas pack this means the /lib/nodes/ dir is what you want to drop in your root (see joreg’s screenshot). I think if you put something higher up in the folder structure (eg the xmas top folder) it won’t work.

I unzipped again beta27 + addon, using 7-Zip : fresh instal (excl. any contibutions dirs) listed 1346 nodes, what seems to be OK.
I think I had again some problems with previous unzipping (Winrar32): NodeList counts 872 nodes only (inkl. my all contibutions dirs)

I had a similar problem (.fx files not showing up – and perhaps other nodes I wasn’t missing yet).
It was due to me installing the Addonpack inside the lib folder instead of next to it. (And I think I did the same with the Xmas-Pack)
Deleting the (thus faulty) lib folder, re-unzipping it from the original install zip, and then placing the Addon- and Xmaspack folders neatly on the ground next to the lib folder solved the issue.