Beta23 access violation at adress 005670C0

hi everybody !
i have this message every time i m using a spread with texture. any clue on how no to violate ? Read of adress 0000040

here attached images are in their full resolution, setting them to 1280 doesn t solve anything (1.3 MB)

please any help ? nobody on the line ? youoououou ?

hum… it seems this question falled in a cathedral reverb plug in…

I think all are busy with the node10 festival, I’m sure you’ll get an answer by monday or tuesday.

it’s a pity, karistouf, that you are not here at NODE10… :(

yes i know, i would be really HAPPY to meet you. but here i have plenty of work until february and a buggy show performing … i m chilling with each calling to the spread subpatches… ( notcie i m not loading / unloading patch, just activating them when the alpha is > to 0)

anyway have a good NODE 10 and please drink a fresh bier with a think to the poor vvvvboys far away from node10;-)


ai west,

i don’t see anything suspicious about your patch. also it just works for me. have you tried with beta24.1?

the only strange thing is that the textures are huge and mostly have unused pixels. since they are >2048px in height on a graphic card that only supports pow2 side-length for textures they will be scaled up to 4096px each and thus occupying quite a large amount of texture memory.

seems to me as if you could easily make all those textures 128x1024 px and save a lot of memory and loading time.

hi joreg, its karistouf, not west. I hope you were happy from Node10 ;-)

about textures: all the spreaded quads with textures are giving this access violation notification. this patch is the simplest one of the show. I have 4 subpatches using spreadedtextures on quads.

this is happening even with images rescaled to less than 1920x1080 size. I have resized all my media to feet a height or a width of 1920 max.

i m using ATI card on this show, on a asus laptop.

i m not using load patch technique, as in theatre and dance we are mixing a lot, not calling seperated sequences ( well i presume this is also my way to do videos)
so i m using the >0 condition to enable the quad.

is there an other way to do and preserve GPU ?

separated this patch doesn t give any trouble. putted with all the system, i m running in this access violation.
problem is that all the patch and media is a weight of 4GO, wich is quiete heavy to send you ;-)

ah, the karistouf one. sorry for the hickup. i missed you both at node…

hm, still hard to guess then. can you attach an Info (EX9.Texture) below the FileTexture (EX9.Texture) and see what width/height it returns for the textures of that patch?

also see if it makes a difference if you disable the Repair via Inspektor in on the filetexture.

hi joreg, yes that one ;-)

i have tested with another subpatch in this project, in wich i m making a get slice from dir and not using spreads of the same texture. I m getting the texture from 80 textures in the directory and moving inside of them with performers on stage.
i have also the same error in my TTY while i m making a getslice of the texture

on this patch, taht doesnt uses spreads
the 80 textures are giving in info node 1309 width * 252 height
depth 0 levels:11 Format X8R8G8B8 Type texture Format BMP

The TTY show off on each call to getslice following message:
00:05:16 * : [Validate Value: error occured in ](Validate Value: error occured in ):Access Violation at address 005670C0 in module ‘vvvv.exe’. Read of address 00000040

then i have2 times repeatedthe same message:
00:05:16 - : Texture D:\mypath\image046.jpg (Width: 1309, Height:252, Format X8R8G8B8) loaded un 0.010 seconds.

I began really to have a big headeach on this topic, because knowing that you have a show performing with wrong messages like this is chillling, especially when you are not aboard the touring time …
the patch was running ok during one week rehearsals and 7 performances. until one week ago where SlimDx was broken just before performance ( i presume due to this access violation)
we had to (by telephon) reinstall slimdx, then to clean sizes of certain images too heavy, and cut off a certain number of spreads, trying to keep effects and moving on a more lighten patch.

should i do a resize of all textures to same type of classical size ( your suggestions of formats in jpeg and bmp ?) and then rescale the texture and the quads to get back my visual composition of images ?

what is your opinion about all of this ?
are you interrested to have access to the all project to see what s going on ?

could be pow2 stretch pin be a solution ?

yours, mister karistouf

joreg ?.. no text …


don’t know. personally i’d always work with .dds files and try to make them have pow2 side-lengths. just not to think about that part anylonger.

one more thing you could try: when you get the error in TTY press CTRL+F9 to switch to debug mode. the node throwing that error should be colored orangish. which is it?

another random guess: try setting the Draw Slicewise on the quad that receives the spread of textures to 1. shouldn’t make a difference, but who knows.

hi joreg.
i m letting this work in beta23, as 24.1 is asking more ressources from the graphic card, and i m thinking to be somehow to the end of its limits.

i have done CTRL+F9: i have no orange node
just the IO/node input pin inside the subpatch being orange.

Inspektor > quad > Draw slicewise doesnt do nothing and the access violation is the same. I have done this change and saved, closed and reopen my all patch, without any luck at all…

mkay… think we are out of luck here. as long as there is no simple way to reproduce this i don’t have any more ideas.

ok. do you mind if i put the project on my ftp ? would be great to understand whats going on really …

hi joreg, have you got some time to have a look in the project ?
many thanks

what a paaaatch…

ok, lets see if i get what you get. please try the following:
in visu_uc33.v4p you have three AsString (Value) that each go into a Text (EX9) titled “valeur”. si? replace those with FormatValue (String). a simple doubleclick and replace should do. is that it?

and to get rid of the textureloading try Preloader (EX9.Texture)

waow joreg, i easely can imagine you with a petzel around the head, going in deep immersion of nightmerous patch… really many thanks for your time and patience, and sorry for the inelegance of this patch ;-)

for format string, thats the BUG ! ( champagne or beer ?)
I presume i need to make this change everywhere in my Gui is that right ?
at the beginning i was having the feeling that it was coming from the +(string) node. but nei nei nei… what a buuuug for what a paaaatch ;-)

I will try to inject Preload and see how it works.
i m not really understanding its topic in fact.

other little question: does a hide and lock is interresting on this type of patch, what is your opinion about it ? ( i m not touring the show )

signed: a vvvverrrry happy karistouf !

you’re welcome. thanks also for your patience. on my crusade i came across two more bugs…horray.

the actual problem is not the AsString (Value) itself but the fact that the enum it was set to was not valid. so you could also simply set the enum to Integer (0…MaxInt) for example and it should work as expected.

the idea is to have textures preloaded into the graphiccard on startup so vvvv doensn’t have to load during a performance (which can cause some framedrops). check the preloaders helppatch and start a new thread if needed.

i’d rather recommend a more structured way of patching that would not need hide/lock. the main patch should consist of only a handful of main suppatches, like e.g:

  • ExternalInputs
  • Logic
  • Szene1Stuff
  • Szene2Stuff
  • Szene3Stuff
  • RenderSetup

like this a main patch could be quite understandable. then put your mess in subpatches that are closed anyway. see?

hi joreg, thanks a lot.
very clear answer and happy you founded bugs…

thanks for your suggestion of patching. i m actually thinking hardly on a framework dedicated to dance and theatre that can be easely used by anybody and surely willl work on it on next creation.

does vvvv team have a postal adress ?