Forum

Best way to avoid empty subset in mesh dx11

I’ve been making some meshes, at the moment for dx11, I use cinema4d, when I export a mesh, currently been trying .x and .obj its fine when I don’t add a texture in c4d, I get 1 subset per object, but I don’t get a texture in v4 then.
If I add a material, I get 3 subsets per mesh in the object file, so if I have 3 meshes, I get 9 subsets, the first gives a lyout message of
Object reference not set to an instance of an object.
The next is the object and the next is empty.
This never worked completely right in dx9 either TBH, so is this a c4d issue?
Is there anything I can do about it?
Ideally I’d like to be able to have separate objects, but no empty subsets!

Subsets issue (23.1 kB)

Looks a bit like an extrusion with 0 depth or something? 2 of each trio is a Cap which is why I wonder? Maybe making the source object editable and joining before export would help. Also have you looked at a plugin for C4D called riptide? It’s an obj exporter with a lot more options then the native one.

yo bro it’s because your caps are not connected to other part of model:
select the 3 objects “circle”+“circle:cap_21”+“Circle:cap_12” and then right-click on them and select “connect objects+delete”. Do this again for “Circle_1”+“Circle_1:Cap_22”+“Circle_1:Cap_1” and “Circle_2”+“Circle_2:Cap_2”+“Circle_2:Cap11”.
And voila! you have three models, three circles now re export obj and layout message be “ok ok ok”.

Here is a screenshot of final c4d file and I put three texture just to show it works even with different textures on models… Also reupload your v4 patch and new working model. This happens when c4d flattens/makes your model editable on extrude/sweep nurbs/etc it’s not very clever with caps and doesn’t connect them, found a way to change that in the software settings but can’t remember anyway “connect objects+delete” works…
Peace, Hope it helps.

ObjectSubsets2.zip (46.5 kB)