AudioIn (BassAsio) missing?

Hello, I’m trying to create this node “AudioIn (BassAsio)” from Vux’s BassSound.dll collection.

It does not appear in the list of nodes in vvvv’s node browser.

When I load the help file “addonpack/plugins/AudioIn (BassAsio) help.v4p” the node is red with this message:
“:PLUGINS:\BassSound.dll\vvvv.Nodes.BassAsioAudioInNode” is missing. (id0)

Other nodes relying on BassSound.dll load succesfully, such as AudioOut (BassAsio).

I have tried with a fresh install of v45beta26 and the addon pack. Does anyone know why it isn’t working for me?

(Edit) I should also ask, is it working for anyone?



good find, thanks. i fixed that for versions >b26. for now you could try with beta25 and its addonpack.

Brilliant, cheers.

This is seems to be a temporary workaround in case anyone else wants AudioIn (BassAsio) node to work in beta26.

Edit the addonpack/nodelist.xml file and add the following node:

<NODE factory="VVVV.Hosting.Factories.DotNetPluginFactory" systemname="AudioIn (Bass Asio)" name="AudioIn" category="Bass" version="Asio" filename="plugins\BassSound.dll" ignore="0" autoevaluate="0" type="Plugin" arguments="vvvv.Nodes.BassAsioAudioInNode" ibs="0,0" iws="0,0" icm="0">
</TAGS><HELP>Input node for bass asio
</AUTHOR><PIN name="Descriptive Name" direction="Configuration" subtype="String" slicemode="Single" visibility="OnlyInspector">
</PIN><PIN name="Device" direction="Input" subtype="Integer (0 .. -2147483648)" slicemode="Single" visibility="True">
</PIN><PIN name="Channel Index" direction="Input" subtype="Integer (0 .. -2147483648)" slicemode="Single" visibility="True">
</PIN><PIN name="Channels Count" direction="Input" subtype="Integer (0 .. -2147483648)" slicemode="Single" visibility="True">
</PIN><PIN name="Enabled" direction="Input" subtype="Integer (0 .. 1)" slicemode="Single" visibility="True">
</PIN><PIN name="Handle" direction="Output" subtype="Integer (-2147483648 .. -2147483648)" slicemode="Manual" visibility="True">
</PIN><PIN name="Status" direction="Output" subtype="String" slicemode="Single" visibility="True">
</PIN><PIN name="ID" direction="Output" subtype="Integer (0 .. MaxInt)" slicemode="Single" visibility="OnlyInspector">