Forum

Audio in not working

hi - i can’t understand why i can’t get audio in to work, even the audio in help patch doesn’t work…audio in is enabled, correct driver selected…what next?

maybe that´s a problem with the selected input in your soundcard setting
try to open the soundcard panel and v4 in the same time and select stereo mixer for recording,

tried that, still no luck, i’m using bog standard internal soundcard (realtek), it works fine with demanding audio apps like Ableton Live, Orion Platinum etc, so i can’t see it being a driver issue…

righty, it definitely aint a vvvv issue - which doesn’t come as no suprise.

I tried using vvvv on another install of windows xp i have on my machine - it is a clean install that i haven’t really messed around with (as opposed to my main partition, that has a version of xp that is very customised (running BBLean instead of explorer etc.). Whilst this rarely causes problems i have found that a few apps don’t like it. Thus it seems vvvv also doesn’t like it - i am not sure what it isn’t liking though, that is preventing it from accessing an audio stream. Interestingly the only other app i have had problems with on my maing partition with the customised version of xp is Resolume, another VJ app, it’s file browser doesn’t work, nor does it’s audio analysis, yet, on the other non-modded version of XP it works like a charm.

Wierd huh. BTW, by modded version of XP, I mean I have followed some suggestions posted around the net for how to optimise your system for audio processing (i.e. turning of some windows services by default and changing some hardware settings, i’ll see if i can reset those and find out what is screweing with vvvv).

Thanks for the help sanch - as usual it is user/hardware error. Cool VJing projects and patches btw - when i can get them to work!

default debugging tip:
open a renderer (TTY) window in your patch and look for error messages there.

aha, well, when i do that (insert renderer TTY) into an empty patch, and then insert an FFT 4 channels, this is what i get in the TTY window:

00:00:29 * : patch C:\vvvv_33beta1230\vvvv_33beta10\vvvv_33beta10\ modules\tonfilm\modules\FFT4Channels (DShow9 Resample).v4p
has been marked as changed because of convertions
(from http://vvvv.org/versions/vvvv33beta7.4.dtd to 33beta10). you will be asked for OVERWRITING your patch with the updated version…
00:00:29 : Adding samplegrabber and null renderer
00:00:29 ERR : A specified class is not registered in the registration database.
00:00:29 * : Error creating samplegrabber and null renderer
00:00:29 : Adding node to filtergraph: FFT (DShow9)
00:00:29 ERR : This method tried to access an invalid pointer.
00:00:29 : getting output of SampleGrabber
00:00:29 : Getting input of NullRenderer
00:00:29 - : Cannot connect SampleGrabber with NullRenderer
00:00:29 : Adding node to filtergraph: AudioIn (DShow9)
00:00:29 : AudioIn (DShow9).Audio --> Realtek AC97 Audio.Capture
00:00:29 : Adding node to filtergraph: FFT (DShow9)
00:00:29 ERR : This method tried to access an invalid pointer.
00:00:29 : getting output of SampleGrabber
00:00:29 : Getting input of NullRenderer
00:00:29 - : Cannot connect SampleGrabber with NullRenderer
00:00:29 : Removing node: Realtek AC97 Audio from filtergraph
00:00:29 : Adding node to filtergraph: AudioIn (DShow9)
00:00:29 : AudioIn (DShow9).Audio --> Realtek AC97 Audio.Capture
00:00:29 : Adding node to filtergraph: FFT (DShow9)
00:00:29 ERR : This method tried to access an invalid pointer.
00:00:29 : getting output of SampleGrabber
00:00:29 : Getting input of NullRenderer
00:00:29 - : Cannot connect SampleGrabber with NullRenderer

hmm, doesn’t look good to me…

This is what renderer TTY shows when I do the following to an empty patch:

Add Audio In
Add FFT
Connect audio of Audio in to FFT

This:

00:03:50 : Adding node to filtergraph: AudioIn (DShow9)
00:03:50 : AudioIn (DShow9).Audio --> Realtek AC97 Audio.Capture
00:03:50 : Removing node: Realtek AC97 Audio from filtergraph
00:03:50 : Adding node to filtergraph: AudioIn (DShow9)
00:03:50 : AudioIn (DShow9).Audio --> Realtek AC97 Audio.Capture
00:04:09 : Adding samplegrabber and null renderer
00:04:09 ERR : A specified class is not registered in the registration database.
00:04:09 * : Error creating samplegrabber and null renderer
00:04:29 : Adding node to filtergraph: FFT (DShow9)
00:04:29 ERR : This method tried to access an invalid pointer.
00:04:29 : getting output of SampleGrabber
00:04:29 : Getting input of NullRenderer
00:04:29 - : Cannot connect SampleGrabber with NullRenderer

“specified class not being regitered in the database” looks like the problem, though I’m buggered if i know what it means…

Googling this phrase gave this website:

link

where someone had a problem with a computer game. It seems my error is related to this one, something to do with an error with CoCreateInstance link

Thus I seem to have some registry errors (i use CCleaner to clen up my harddrive, it seems it may have been to keen to clean up my registry as well). Any idea what registry entries I need to fix this or if there is somethign i can install to fix this?

using the vvvv deinstaller will remove all registry settings, and starting vvvv will install all necessary things. so i dont see any need to do registry tweaks when using vvvv. do you have admin rights? running vvvv without being administrator may cause installation problems (after running vvvv once as administrator, you should be able to go back to normal settings)

we´ve never heard of general problems with vvvv and Realtek AC97 Audio drivers. does the plain old windows Audiorecorder work on your systems? which drivers can you select in the AudioIn node? are you sure that no other program (Skype, CD ripping stuff, etc) already opened your AudioIn port?

tried vvvv deinstaller, followed by a restart of vvvv - but it still doesn’t work. I am guessing it is a problem with my DirectSound registry settings, not vvvv registry settings.

I’m logged in as the administrator permanently.

The plain ole Windows Audio Recorder works fine, it is able to record and playback an audiostream from Foobar. The only driver I can select in the AudioIn node is the Realtek Driver and I closed all the other potential audio using apps before starting vvvv (cheked via Task Manager). Still no dice.

VVVV still works with my clean install version of Windows XP on a separate partition, so there is clearly something wrong with my main install. I just can’t figure out what…

from the tty output to me it seems as if samplegrabber or nullrenderer are missing. which is strange since they are both standard windows directshow filters. vvvv is only using them. i have no idea why they should not be present.

you could check that with a tool like graphedit (google for it). or max mentioned another tool that lists installed filters? nullrenderer and samplegrabber should be listed among the “Directshow Filters” category.

Maybe you are right - Graphedit lists a load of things in the Directshow Filters category, but nothing uniquely called nullrenderer or samplegrabber , althought there is a Nero Digital AVC Null Renderer…what exactly am i looking for. If it aint there, which it appeats not to be, how can i re-install them? I’ve already tried updating DirectX using microsoft’s site and re-installing the latest version WMP (though i couldn’t completely remove WMP first - it wasn’t listed in the Add/Remove Programs list - even though it was installed)…

Thanks people for looking into this for me, hope we can fix it…

I think i have fixed it. I installed ACE Mega Codcecs Pack which also didn’t show nullrenderer and samplegrabber as being installed. Not knowing what to install, i told it to install all codecs, not an ideal situation i know, but…it works, i now have fancy audio responsiveness…wohooo

Hopefully it is a permanent fix - thanks people for helping me out - i only hope the problem doesn’t resurface when i reboot…

EDIT

Well, it seems like a permanent fix, vvvv audio in working fine now. Guess what though, Blender now isn’t loading!!! My system is more screwed than Bin Laden ending up in the Whitehouse after a drunken night out with the boys…
roops