Arduino can`t connect in gamma

beta gamma

As these two picture.I can connect my arduino by vvvv beta but cant connect it by vvvv gamma.I tried press "reset" button or press "Enable" to restart,but its not work.Please help. :-)

Hello 11,

looks strange. May I ask you if you’ve disabled the FirmataBoard in vvvv beta, before trying to enable FirmataDevice in vvvv gamma? Sure you did, but just doublechecking.


Thanks Anton.

Before I opened vvvv gamma, I closed vvvv beta.

which version of vvvv gamma are you using there?

I`m using vvvv gamma 2021.3.2

hmm. we’re not aware of any problem like that with this version. can you still please try with 2021.3.3?!

OK, and here is the detail of my problem.
After pressed the “enable”,arduino flashed several times.Then at the moment I were pressing “reset”,it will “on data”.

i’m afraid this gif is too small to see anything…
also did you test this with 2021.3.3?

Yes, I tried 2021.3.3 , and it`s the same problem.

Here is the detail video. (2.4 MB)

Hi 11,

would you please let us know what Arduino board are you using, which Firmata version is on the board and how you’ve flashed it.

Ah, your first screenshot is telling that this is 2.5 StandardFirmata, right?



Hi, robotanton

I`m using DFRduino UNO V3.0.

The version of firmata is “StandardFirmata” example patch in Arduino IDE. I think it is 2.5 StandardFirmata.

Firstly,I pressed “enabled”,and it flashed several times.(“on data” is false)
After it was not flashed and when I was pressing “reset”, the “on data” flashed just a moment,and Extinguish suddenly.


I tried using arduinoUNO R3,which is made in Italy.But it still not work.

@user1 please test again with 2021.4.10
we’ve stumbled upon and fixed an issue that may be related.

It works well with 2021.4.10.
Thanks a lot :-)

I’m encountering a similar problem. I tried on Beta and the firmata ready box turns on, but when I try it on gamma the firmata ready box won’t turn on. I’m using vvvv 2021.4.12, and arduino nano. The firmata patch I’ve loaded is standard firmata. I’ve been testing with the sample analog read write, and digital read write in the help menu, and the firmata is enabled in dependencies. Anyone know what might be wrong?

Do u close your arduino IDE before using your vvvv patch?

Yes I did (that had been a problem before). I can get the firmatta to work, just not consistently. 1/10 times I open it, it doesn’t seem to work and it get’s fixed by exiting the programme and restarting. So it works fine for now, but I would like it to be consistent.

Yes, it’s a bit inconsistent, but I think this is a serial hardware and the microcontrollers architecture.
If it stops working with your microcontroller, reinstall arduino ide.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.