App export stuck - Gamma 2021.4.5


All exports from Gamma get stuck at the beginning. (Tried to wait a whole night, no error but no progress)
Gamma 2021.4.5
VS Build Tools 16.11.9
VS Studio community 16.10.2

I tried different patches (including this test with Exemple Repelling Circles.vl, see log below)
New Text Document (2).log (48.5 KB)

I tried different Output directories on different hard drives.

I tried Clean Output checked/ unchecked
I tried to delete all content in Exports before exporting (including /src)

I tried to Repair VS Build Tools.

I’m planning to try with a previous Gamma version, and to reinstall VS Build Tools

Thank you!

I tried with Gamma 2021.3.3, the export for the same patch (repelling circles) works perfectly, and the export is super fast.

Do you by any chance have access to another computer where you could try it? Or maybe create a local Test user and try in that fresh account? The error you get (ssl stream disposed) doesn’t tell me much except that the net seems to be full of similar reports with no solutions…

Thank you Elias,

I tried on another computer:
(laptop Hyperbook):
VS Build 16.11.9
Gamma 2021.4.5

New Text Document (3).log (97.7 KB)

It get stucks after a long struggle (same behaviour as the other computer)

It fails to download any packages it seems. All requests seem to time out (from the log). For example - downloads just fine here. What truly is disturbing why it works in 2021.3. Could be that it’s a different package version it’s looking for which it has cached locally already. Sticking to the Stride.Input example, if you navigate to %HOMPATH%\.nuget\packages\stride.input, do you see the folder there?

I have this only:


Aha yes, that’s the version we’re using in 2021.3. And you see that folder on both computers? That would explain why it works on 2021.3. In other words if you rename that .nuget/packages folder the export with 2021.3 should also fail.

So we have to figure out why both your computers won’t connect to anymore - or let’s say they both fail to download from there.
If you click on that package link above, does you browser download it normally?

If I click on :
the download is very fast

Let’s try to do some steps manually. Please download to SOMEFOLDER, open a command line (Win+R → cmd → Enter), and type

nuget install stride.input -version -verbosity detailed

You should end up with a bunch of packages in SOMEFOLDER. Does this work?

log.log (52.2 KB)
It looks like it’s working

Hm from a quick Research in other software tools it seems to behave the same. Nuget.exe works but when run from inside an app it fails. Didn’t find any thread yet where a solution was presented. Not sure what’s going on here :(

Thank you for the info.

I tried on another computer, and with another internet connection : export doesn’t work as well.

Am I totally unlucky with these 3 computers, or this is the same result for everybody ? : it’s right now impossible to export anything when you don’t have already all the nugets previously downloaded in your %HOMEPATH%.nuget\ folder ?
Could somebody try on a computer without a previous VVVV install?

My guess is that something changed recently on the side of
It was working for me previously with this PC (I tried this export feature with success last summer, that’s why some nugets are installed on my pc)

Just deleted my local packages folder and it worked fine. So it must be some sort of misconfiguration.

What Windows version are you using?

For reference this is mine:

Can you check those registry keys as outlined in this article?

In my case they’re all not present (how it should be).

And last but not least upcoming preview build will have an updated version of the nuget API - maybe that helps (even though I doubt it).


I’ll try a Windows update.

As for TLS 1.2 support, it looks ok on this computer:
tls.log (1.3 KB)

I tried these commands to enable TLS 1.2:

  • Run the following commands to enable TLS 1.2 support if it is disabled:
reg add "HKLM\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Client" /v DisabledByDefault /t REG_DWORD /d 0 /f /reg:32
reg add "HKLM\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Client" /v DisabledByDefault /t REG_DWORD /d 0 /f /reg:64
reg add "HKLM\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Client" /v Enabled /t REG_DWORD /d 1 /f /reg:32
reg add "HKLM\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Client" /v Enabled /t REG_DWORD /d 1 /f /reg:64

and… it works!
I tried many exemple patches with successful exports.

The weird thing is, when I query the TLS support commands to verify the state of TLS on the computer, I have the same results as before…
But anyway, it works.

Thank you for all the help!

Omg. Glad it works now. Do you know did you have any entries there before in the registry? Or if you delete them does it still work then? I simply wonder why it would be configured n different ways. Especially as you say on three computers.

I tried these commands on another computer (laptop Hyperbook) to be sure, and unfortunately, it doesn’t work there, unsuccessful export :(

I’m pretty sure I did not have entries before in the registry of Computer 1 (MSI), and I’m pretty sure these TLS commands did nothing, as when I query the entries now I have the same results than before .

Other things I did on Computer 1 (laptop MSI) that could influence the successful export:

  • I started trying exporting with another example patch (Branching rather than Repelling Circles)
  • I installed a new package (Fuse)

I tried these steps on Computer 2 with no success.

I don’t want to bother you more with this problem, but I’ll continue to investigate and I’ll post here if I find anything interesting.
And now it’s working on Computer 1 :)

And now it’s working on Computer 2!

I did all the previous steps + changing hard-drive path for export.

Export the 2 examples successfully (Circles and Branching).

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.