Forum

Any node for Printer?

Hellllo everybody I 'm working on a drawing patch and I would like to have an easy way to print (with my printer) anything that’s in the renderer. Is there any node that can communicate with the printer

TnkX in advance…

as far as i know… No ;)

but…

you can save everything thats in your renderer to a file (check WRITE-nodes and their helpfiles)

with a change->tog edge->do write combination it would be a comfortable and powerfull solution ;)

and you can do some changes in photoshop or a batch printjob afterwards…

greetz
grobkorn

You can do that with the Shellexecute node.

You can use the “print” commnand .

Thnx s3aves this is what I was looking for…

hi!
1 question maybe too stupid for the devs:

I tried the shellexecute command (attchd) with the “print” command but after the bang the only thing i see is the image-fax viewer poping up with the last image saved…

so why no command is sent to my usual default printer?!

thank you guys

tick.v4p (8.7 kB)

i mean…
is there any way to print directly after the bang?

i m not able to understand the “port” node pins

nono…

check the ShellExecute (VVVV)'s helppatch. on the File you have to link to the cmd.exe, then you should be able to specify via Commandline Arguments something like:
/c print /D:lpt1 filename.bmp

untested, but this should be the way to get this to work.

the Port (Devices) is for special interest direct communication with the parallel port. not suitable for your quest i’d say.

tx clear now
I had a look in the cmd glossary (windows help F1)
but anyway it doesn’t work…

I set my printer (a hp usb) on LPT1 port (correct?)
and set the vvvv patch as the one attached (have a try, please)

but after the bang nothing happens
I also tried to change /d:lpt1 into /d:usb00 or other but…nothing

I also tried:
typing in dos window “print /d:LPT1 C:\path\file.bmp” and the message is “impossibile inizializzare la periferica lpt1” thet obviously means “i don’t want to make you happy through my lpt1 port or other…”

Could it be a printer error or syntax error??

many thanks

here’s the new patch

tick.zip (139.7 kB)

i’d suggest you first solve the vvvv-unrelated problem of printing from the commandline. when that works, try via shellexecute again. i have not further experience with that but am quite certain the google knows more.

Hard googled…
The problem around usb printers is that cmd only recognizes LPT or COM ports, so if you don’t have a network printer you have to install microsoft loopback and share the printer…

I found an easier way to print pictures from vvvv via shellexecute:

Using the free tool irfanview http://www.irfanview.com/ that have a lot of options via command line and prints directly on my default usb printer(just 1mb) (image and fax viewer could do the same, maybe?)

how in vvvv:
In ShellExecute file I put the exe path of irfanview.
In Commandline Arguments I put the picture complete path + the command /print (C:\path\file.jpg /print).
In this way irfanview prints in background on my default usb printer.

put together the information in these threads and a texture printing plugin would not be super hard to do, i think… except that it is currently not possible to make plugins with a texture input pin ;(

but here:



http://www.devarticles.com/c/a/C-Sharp/Printing-Using-C-sharp/
http://ondotnet.com/pub/a/dotnet/2002/06/24/printing.html