Forum

Alpha28 Freeze with dx9ex enabled

[Mainloop.TMMainloop.DoTimer: error occured in ViewPatch.TMViewPatch.UpdateViewCB](Mainloop.TMMainloop.DoTimer: error occured in ViewPatch.TMViewPatch.UpdateViewCB): Leinwand/Bild erlaubt kein Zeichnen

I’m trying to narrow down the cause of this freeze so I can post a path, but any clues as to whats wrong would be great!
After deleting some bits, I was getting lots of group exceptions too…
There are 2 large (3x1, 2x2 eyefinity) fullscreen renderers, with a stream of video going to each (but not both)
dx9ex is enabled, and the 2x2 renderer with spreaded viewports has a dxTexture for doing a depth map, this last thing seemed to be the thing that broke it, havent managed to simplify this yet however…

vvvv.exe-exception-2012-08-06.log_.zip (5.4 kB)

Here a patch that shows the error however…
as it is now with the 2 renderers on 1 screen it doesn’t seem to happen, when one is on another screen, I get a exectptions pop up and the
Mainloop.TMMainloop.DoTimer: error occured in ViewPatch.TMViewPatch.UpdateViewCB: Leinwand/Bild erlaubt kein Zeichnen

if they are on 2 other screens from the patch, I get the freeze, but what I have noticed is that its mostly a freeze, I think there is an invisible excpetions dialog that I cant click to continue, as I see something pop up on the patch before freezing.

The movies are 2 mjpeg avi’s PICvideo4 (3072x2048) and the audio is 1.5m of LTC timecode, I can upload these some where if you need?

patch for bug (31.3 kB)

and there is no such problem when not using /dx9ex ?

Without the args the patch runs normally
Could it be todo with video playback?

However, after starting work on the patch after testing without the args, the ui has gone weird, if I open a patch window, I get the borders of the window but the insides are transparent, so you can see patch behind and desktop behind that.
On quitting the quit dialog was also transparent and although the buttons you could see, still worked…

wow, so do i get it right? this weird ui stuff also happens without /dx9ex, ja?

so hard to guess, but sounds like a memory problem. with dx9ex enabled there is some additional graphics memory overhead and with you playing huge videos there is already a lot going on. still of course no reason for anything to fukc up this way…have you tried disabling windows aero UI?

The transparent windows happen in beta27.2 too it sea, I can work for a while then I open a patch and nothing there!

Ah ok, I’ll give that a go…

I should point out that we have 2 gfx cards one for each renderer, video is piped to them individually, so while they are big, the cards should be ok, theyre eyefinity6 so really should handle large textures…

Aero off, still have the ui errors, in fact they don’t stop there, if I try and create a node I can type but don’t see the nodes list, or my typing, and finally I had an Microsoft .net framework error window pop up with big red x’s where text and buttons should be!

cheeseus! but this is only with a big project? or does it happen as soon as you start vvvv? does tty report anything? how about graphic drivers?

For comedy here are screenshots…
pictures aren’t being included in posts…

error pics.zip (168.5 kB)

I’m currently testing some different codecs, but h264 in an avi wrapper still seems to be leaking memory (I did notice that memory in the task manager has been increasing at quite a lick, 2MB per second with pic video, which is strange as my last project had 5760x1080 video x 2 and the leaks were 4k per second or so.)
Trouble with h264 is that I have to sync them to a audio file, and they don’t like being sync’d!

I’ve got a workaround, I’m using DDS, I had stopped using them as the frame rate was iffy, but I discovered that if I closed the TTY the frame rate was fine, so as a feature request, can we filter the TTY in some way, as I like it open but when you do image streams, they write into it every frame, meaning you don’t see the errors you need!
Obviously if you can fix the above video issues thats great ;)

hm…since there is nothing i can reproduce here i am not sure what to fix.

So the patch doesn’t break for you then :/ It does take a minute or 2 to happen here, but is consistent.
O Well!

I’ve just tried beta 28, when I load the patch, which works perfectly in beta27, some collada models are missing bits, and inverted in scale, whats changed with collada?

The patch slowly become unresponsive, and eventually the gui vanishes, while the renderers still output.
I’m uploading a video file for you to test to www.colour-burst.com/Downloads/3ktest.avi (this is saying an hour to ul at the moment, so I’ll report back when its done)

When testing with the bug patch above, it starts ok, but after a few mins throws exceptions, and the exception dialog, which appears and can be read as the renderers aren’t fullscreen, is in d3dx9_38.dll and the exception log is attached.

vvvv.exe-exception-2012-08-16.txt (22.9 kB)

Also are you moving the renderers to extended displays? Preferably one on a different gfx card, as this seems to be the root cause… (and the dx9ex switch)

Ok, file is now online.

i cannot even play that file. tried with windows media player and vlc …