Forum

Alpha & depthbuffer

Hi-ho!
I’ve got a little problem: i’m using 3D animated objects textures with alpha channel, but whenever I switch on the depthbuffer format, the alpha channel passes the background color but hides 3D objects behind.

See what I mean?

Thank you for your help,
Cheers.

Alecz

Music Swarm-DirectX Renderer_2007.03.08-12.05.51.jpg (13.9 kB)

depthbuffer with alpha is a well known problem in 3d graphics. but try the node AlphaTest. connect it to the objects that have the alpha texture and try different settings. it doesn’t work in all cases, but helps in most…

Great! I didn’t see that. It works pretty well (the depth is, at least, correct) but there is an ugly white border around the texture. Gonna work it in Phototshop.

Thank you tonfilm, you rule!

PS: I watched your video on your myspace page, nice lighting and the A/V sync is perfect. Bravo l’artiste!

the AlphaTest node has a Alpha Reference input, it can reduce the aliasing on the borders.

… and thanks for your comment to the video!

this unexpected annoyance of the depth buffering algorithm comes up again and again. funnily enough, we even have an faq entry about this. anyway there are still things on the wishlist…

Nice! Thanx oschatz, that’s helpful form an eternal newbie such as me! ;]

Cheers,
Alecz