3D file with 1 object shows 3 meshes in Mesh(DX11.Geometry.Asimp)

basically what the title says. I have one mesh in C4d with normals, texture, uv and phong tag. regardless of exporting as obj or dae 1.4 - I have to use a getslice (Node) to read the mesh data.


Have you tried using SceneExplorer? It could show some useful stuff.

probably the mesh has to many vertices, so it gets divided in subsets. I use a Merge from instance noodles in those cases.

Thanks for the sceneExplorer tip!

I thought that 50k vertice limit was just a unity thing. I can confirm that meshes above 50k will get split. The empty objects correspond to the number of objects above 50k, but their placement in the hierachy seems random.

Interestingly, the pointcount shown is much much higher than in my c4d project. please have a look at the attatched screenshot. I already tried discarding all unused points.

Unbenannt Unbenannt2

none of my c4d meshes has above 50k vertices!

each face in a mesh can have different materials and the assimp importer split the mesh into individual groups of vertices assigned to one of the materials. that’s why one object with one mesh can have 3 slices of geometries. you can see info about this in sceneexplorer or in the Node (Assimp) node

whaaat? I had always 50K+ vertex meshes and assimp didn’t break them up based on their size
the biggest I successfully imported with assimp had 4 million+ vertices and that was a single slice

ok this was just an assumption. I know that unity splits over 50k. I just try to understand what is happening here. All meshes use the same material and no face selection.

check if C4D doesn’t create automagically material vertex groups in blender for example also factor in the fact that C4D exporters are really messy.

The point count discrepancy may come from the fact that 3D packages only count a point on a single position, but that point can have different normals, texcoords and other jazz for individual faces in which case Assimp rightfully splits them into “duplicate” vertices.

I removed the normals, uv and texture within c4d and exported as obj and dae. explicitly without normals or uvs.

no change in point count…Unbenannt3

yet… more colorful

There is so much crap that you can expect for that to happen. This usually gets fixed by exporting to an obj, then importing back to 3d modeling software and exporting again for vvvv.

There maybe some hidden flags on geometry that you can’t see

WOW. I tried everything. exporting as obj, reimporting, deleting all tags, exporting in different formats - no success.

so here is my fix: importing in zbrush, exporting as fbx, reimporting in c4d, editing and exporting as obj or dae. both work fine now, those empty slices within the scene explorer are gone now.

Well there are hidden flags on geometry that make that happen, usually you can expect to stop that happen by exporting and re-importing stuff in some limited format such as obj, until all the flags are gone…

So far can only recommend to use Maya and Blender are two softwares that recommend them self by not exporting crap underthehood… I guess zbrush is one of them also…

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.